Upcoming Adobe CC Updates Require OSX 10.7 or Higher

Upcoming Adobe CC Updates Require OSX 10.7 or Higher

As a notice to those still on the older OSX Snow Leopard 10.6, the upcoming major Adobe CC updates (for Photoshop and the other applications you may have in the CC suite), will require OSX 10.7 or higher. The much older 10.6 which was released over four years ago, will no longer be supported. The current version of OSX 10.9 is a free update for all Mac users.

However, if you are still using OSX 10.6, your current applications will continue to work. But if you want to update to the newest CC releases coming out, you will need to update your current OS to at least 10.7 if not the newest 10.9. The current OSX 10.9 is a free update for all Mac users.

CC-OSX